You are here:--[Resolved] JS Fehler bei Konfiguration der Ausgänge
[Resolved] JS Fehler bei Konfiguration der Ausgänge 2017-10-28T11:56:39+00:00

Home Foren Fragen während Installation JS Fehler bei Konfiguration der Ausgänge

Schlagwörter: 

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Autor
    Beiträge
  • dakurt
    Teilnehmer
    Post count: 9
    #1435 |

    Ich habe einen Floorgateway Pro (10 V). Bei der Konfiguration der Ausgänge wird bei mir leider nichts angezeigt, da es zu einem JS Fehler kommt.

    Ursache des Fehlers ist, dass die zwei REST Anfrangen auf dieser Seite unterschiedliche Keys im JSON haben. Siehe dazu den zweiten Screenshot. Bei einem Request ist der Key „…gw“, bei dem anderen „…gwv10“.
    Bei dem Zusammenbauen des Arrays auf der Ausgänge Seite entsteht somit ein leeres Array was zu dem Fehler im ersten Screenshot führt (length auf undefined).

    Ich bitte das Problem schnellstmöglich zu lösen, da ich sonst das Setup nicht durchführen kann.
    Alternativ bitte ich um Beschreibung was ich während des Konfig beachten muss, damit die Identifier übereinstimmen und kein Fehler auftritt.

    Dateianhänge:
    You must be logged in to view attached files.
    dakurt
    Teilnehmer
    Post count: 9

    Ein Workaround / Hack besteht darin im Code in Zeile 93 folgende Zeile einzufügen:
    gw2s[„5553840106504192##Gateway##gw10v“] = gw2s[„5553840106504192##Gateway##gw“]

    Maximilian
    Keymaster
    Post count: 50

    Da haben Sie recht, wir haben das behoben.

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.